カートに入れるボタンを押した際にショッピングカートに商品が入りません。考えられる原因は何でしょうか。

コマースクリエイターご利用店舗様専用の記事です

店舗様の構築によっては、カートに入れるボタンを押した際に
「商品が存在しません」などのエラーとなり、ショッピングカートに商品が入らないことがございます。

この場合、エラーが出た商品を設定したパーツの配置に原因がある可能性がありますので、下記をご確認ください。

コマースクリエイターでは一部のパーツ配下ではformタグを含むパーツを配置できません。

formタグを含むパーツを配置できない場所

  • レイアウト:商品グループ・・・・商品一覧(システムパーツグループ)配下
  • レイアウト:商品詳細・・・・・・商品詳細エリア(システムパーツグループ)配下

原因

上記パーツはformタグにて構成されています。
HTMLタグの動作上、上記パーツ配下にformタグを含むパーツを配置しても正しく動作しません。
formタグを含むパーツの一例

  • 任意商品一覧(パターンA ・・・カートに入れる(詳細を見る)ボタンが表示されるパターン)
  • おすすめ商品パーツ(パターンA ・・・カートに入れる(詳細を見る)ボタンが表示されるパターン)
  • formタグを設定したフリーパーツ

 

対処法

<対応案1>
formタグを含むパーツを配置する場合は、上記システムパーツグループの外に配置してください。

<対応案2>
パーツ位置を変更されたくない場合は、表示パターンを B または C へご変更ください。

マニュアル:任意商品表示パーツ(おすすめ商品表示パーツ)の表示パターン

 

この記事は役に立ちましたか?